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Brief： 

This document is the user guide for Telink Burning and 

Debugging Tool (BDT). 
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1 Brief Introduction 

“Telink Burning and Debugging Tool (BDT)” applies to all engineers who want to 

develop applications based on Telink SoCs including 8267, 8269, 8266, 8232, 8233, 

8366, 8368 and 8x5x series.  

This document presents the guide on how to use “Telink Burning and Debugging 

Tool (BDT)”. 

 

1.1 Function Overview 

During SDK development, by using “Telink Burning and Debugging Tool (BDT)”, 

firmware can be directly downloaded into the target board (e.g. development board) 

via USB mode or “Burning EVK” (abbreviated as EVK) mode.           

Its main functions include “Erase flash sector”, “Download firmware”, “Activate 

MCU when communication failed”, “Access memory space including FLASH /CORE 

/ANALOG /OTP”, “Read/Write global variable” and “View USB log”. 

 

Figure 1-1 Main interface 
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2 Operation Guide 

2.1 Download firmware 

2.1.1 Connect hardware 

Before using “Telink Burning and Debugging Tool (BDT)”, it’s needed to connect 

the target board with PC.  

There are two methods to connect the target board with PC, as shown below. 

Method 1: Directly connect the target board with PC via USB.  

This method only applies to target board with USB interface and MCU supporting 

USB function, e.g. a dongle board. 

 

Figure 2-1 Connect target board with PC directly 

 

Method 2: Connect the target board with PC via Telink “Burning EVK” 

TLSR8266BR56. 

1) Connect the “Burning EVK” with PC via USB cable. Observe the indicating lights 

of the “Burning EVK”: The indicating lights will blink once to indicate that the 

“Burning EVK” and its connection with PC is OK. 
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Figure 2-2 Connect “Burning EVK” with PC 

 

2) Connect target board with “Burning EVK”. 

There are two methods to connect the target board with the “Burning EVK”. 

a) Connect the target board with the “Burning EVK” via USB interface directly, 

as shown below. This connection method only applies to target board with 

USB interface and MCU supporting USB function, e.g. a dongle board. 

 

Figure 2-3 Connect target board with “Burning EVK” via USB 

LED 

Burning EVK 
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b) Connect the target board with the “Burning EVK” via Swire (Single wire) 

interface, as shown below.  

 

Figure 2-4 Connect target board with “Burning EVK” via Swire  

 

Please refer to Telink document “AN_18010500_User Guide for Telink Burning 

EVK TLSR8266BR56” for the detailed guide of TLSR8266BR56. 

 

After connecting the target board to PC via USB method or “Burning EVK” 

method, there are two methods to download firmware into the target board, which 

respectively correspond to the two hardware connection methods above.  
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2.1.2 Connect Device 

Before downloading firmware into the target board, please ensure that the device 

have been found by BDT as the following figure. 

 

Figure 2-5 Burning and Debugging Tool 
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 If BDT do not find device as the following figure, you can Click “Refresh” to check 

available device. 

 

Figure 2-6 Check Available Device 
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 If BDT find many devices, all devices will be listed as the following figure. After 

clicking the button “Refresh”, the first device will be connected to BDT by default. If 

you want to connect other devices, you can select the specified device as the following 

figure. 

 

Figure 2-7 Select the Specified Device 

2.1.3 Download FW into “FLASH” via “USB” mode  

Before using “USB” mode to download or debug MCU, please ensure that the 

specified MCU supports USB function and its USB function is available. Refer to section 

4 Function Support List for details. 

 

Then user can follow the guide in this section to download firmware into specific 

flash space of the target board via “USB” mode.   

Step1: Select chip type of the target board, e.g. 8258 (default option). The following 

two methods are supported. 

 Method 1: Use the drop-down menu to select chip type. 

 Method 2: Press the shortcut key combination “Ctrl + Q” to switch chip type.  

*Note: All chip type options and default option are configurable in the “config.ini” file. 
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Figure 2-8 Select chip type  
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Step2: Select download mode as “USB”. The following two methods are supported. 

 Method 1: Use the drop-down menu to select USB download mode.  

 Method 2: Press the shortcut key combination “Ctrl + W” to switch to USB 

download mode. The drop-down menu will automatically show the current 

download mode after each switch.  

*Note: All download mode options and default option are configurable in the 

“config.ini” file. 

 

 

Figure 2-9 Select download mode as “USB” 
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Step3: Click the “Setting” button to open the Setting dialog window. Select the “FLASH” 

setting option. User can adopt either of the following two methods to set the offset of 

flash starting address for target firmware storage, e.g. 0x000000 (default option). 

 Method 1: Use the drop-down menu of “Download Addr” to select the offset 

option available.  

 Method 2: Input the offset address in the editable box of “Download Addr”.  

*Notes:  

1) All setting options and default option are configurable in the “config.ini” file. 

2) User can also configure the “SRAM”/“OTP” setting option so as to download target 

firmware to destination area in SRAM or OTP. 

 

Figure 2-10 Select starting offset address  
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Step4: Select the target firmware file to be downloaded into the target board.  

1) Click File->Open to open the file select window. 

 
Figure 2-11 Open file select window  

2) On the file select window, select the target bin file (e.g. Telink.bin) and then click 

the “Open” button. 

 
Figure 2-12 Select target file and open new file path 
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 The file path will be displayed at the bottom of the main interface. Every time 

when a new file path is opened via the file select window, it will be added to the 

submenu of “File->Reopen”. This simplifies FW selection in subsequent operations by 

enabling user to directly select the target file path available in the submenu of 

“Reopen”.   

 

Figure 2-13 Directly select target file path in the submenu of “Reopen” 

  



                  Telink Burning and Debugging Tool (BDT) User Guide 

AN-18101200-E2           19 Ver 1.1.0 

Step5: Check connection status between the target board and the PC and make sure 

it’s OK.  

 If the status of connection is OK, the left bottom of the main interface will show 

“usb device: ok” or “evk device: ok”.  

 If the left bottom of the main interface shows “usb device: not found”, it indicates 

the connection between the target board and the PC is not available. 

 

Figure 2-14 Connection status indication 

  



                  Telink Burning and Debugging Tool (BDT) User Guide 

AN-18101200-E2           20 Ver 1.1.0 

Step6: Download the selected file into the target board. 

By clicking the “Download” button, the selected firmware file will be downloaded 

into the specified flash space of the target board via USB mode. The log window will 

indicate corresponding log information, as shown below. 

 

Figure 2-15 Download FW into Flash via USB mode 
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Step7: Reset MCU to make the newly-downloaded program run without the need to 

power cycle MCU (unplug/plug from Burning EVK). User can follow either of the 

following two methods to make MCU boot and run. 

 If “manual mode” is selected via the drop-down menu, after FW burning user can 

click the “Reset” button at the top right corner of the tool to manually reset the 

MCU. 

 

 

 

Figure 2-16 Manual MCU reset 

 User can also select “auto mode” via the drop-down menu before FW burning, so 

as to enable auto reset after FW burning. 

 

Figure 2-17 Auto MCU reset 

2.1.4 Download FW into “FLASH” via “EVK” mode 

Before using “EVK” mode to download firmware, please ensure that target board 

is connected to PC via “Burning EVK” method and the single wire communication of 
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the target board is established.  

User can follow the guide in this section to download firmware into specific flash 

space of the target board via “EVK” mode.  

Step1: Select chip type of the target board, e.g. 8258 (default option). The following 

two methods are supported. 

 Method 1: Use the drop-down menu to select chip type. 

 Method 2: Press the shortcut key combination “Ctrl + Q” to switch chip type. The 

drop-down menu will automatically show the current type after each switch.  

*Note: All chip type options and default option are configurable in the “config.ini” file.  

 

Figure 2-18 Select Chip Type 
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Step2: Select download mode as “EVK”. The following two methods are supported. 

 Method 1: Use the drop-down menu to select EVK download mode.   

 Method 2: Press the shortcut key combination “Ctrl + W” to switch to EVK 

download mode. The drop-down menu will automatically show the current 

download mode after each switch.  

*Note: All download mode options and default option are configurable in the 

“config.ini” file.  

 

Figure 2-19 Select download mode as “EVK” 
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Step3: Click the “Setting” button to open the Setting dialog. Select the “FLASH” setting 

option. User can adopt either of the following two methods to set the offset of flash 

starting address for target firmware storage, e.g. 0x000000 (default option). 

 Method 1: Use the drop-down menu of “Download Addr” to select the offset 

option available.  

 Method 2: Input the offset address in the editable box of “Download Addr”.  

*Notes:  

1) All setting options and default option are configurable in the “config.ini” file. 

2) User can also configure the “SRAM”/“OTP” setting option so as to download target 

firmware to destination area in SRAM or OTP. 

 

Figure 2-20 Open the Setting Dialog 
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Step4: Select the target firmware file to be downloaded into the target board.  

User can select the target file via the “File->Open”, or via the “File->Reopen” if it’s 

available in the submenu. The file path will be visible at the bottom of the main 

interface.  

 

 Figure 2-21 Select the Target File 

 

Figure 2-22 Select bin File 

 

 

 

 

Select bin and then click “Open”  
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Step5: Check connection status between the target board and the PC and make sure 

it’s OK.  

 If the status of connection is OK, the left bottom of the main interface will show 

“usb device: ok” or “evk device: ok”.  

 If the left bottom of the main interface shows “usb device: not found”, it indicates 

the connection between the target board and the PC is not available. 

 

Figure 2-23 Check Connection Status 

  

Connection status indication 
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Step6: Download the selected file into the target board. 

By clicking the “Download” button, the selected firmware file will be downloaded 

into the specified flash space of the target board via EVK mode. The log window will 

indicate corresponding log information, as shown below.  

 

Figure 2-24 Download FW into Flash via “Burning EVK” mode 
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Step7: Reset MCU to make the newly-downloaded program run without the need to 

power down MCU. User can following either of the following two methods to make 

MCU boot and run. 

 If “manual mode” is selected via the drop-down menu, after FW burning user can 

click the “Reset” button at the top right corner of the tool to manually reset the 

MCU. 

 User can also select “auto mode” via the drop-down menu before FW burning, so 

as to enable auto reset after FW burning. 

 

 

Figure 2-25 Manual MCU reset 
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Figure 2-26 Auto MCU reset 

 

  



                  Telink Burning and Debugging Tool (BDT) User Guide 

AN-18101200-E2           30 Ver 1.1.0 

2.1.5 Download FW into “SRAM” or “OTP” 

By default, the “Setting” option is set as “Flash”, i.e. by clicking the “Download” 

button, the target firmware will be downloaded into the target board’s “Flash” space.  

User can also change the “Setting” option to “SRAM” or “OTP”. In this case, by 

clicking the “Download” button, the target firmware will be downloaded into the 

target board’s “SRAM” or “OTP” space correspondingly.  

For the TLSR8258, the starting SRAM address for target firmware is 0x040000. For 

other Telink’s SoCs, the starting SRAM address for target firmware is 0x008000. Of 

course, user can set other address as needed in the editable box.   

After the target file is downloaded successfully, the target board will not 

automatically run the new FW in “manual mode”, so user needs to click the “Reset” 

button to make program boot. User can also select “auto mode” via the drop-down 

menu before downloading, so as to enable auto MCU reset. 

 

Figure 2-27 Download firmware to “SRAM” via “auto mode”  

 If target board supports OTP function, user can download firmware into “OTP”. 

Refer to section 4 Function Support List for details. 
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2.1.6 Multi-address Download 

Sometimes, it is necessary to download more than one firmware into different 

addresses of FLASH, SRAM or OTP.  

For example, user can follow the steps below to download “Telink.bin” into the 

address “0x000000” and “0x005000” of FlASH. 

Step 1: Select the destination memory space (e.g. FLASH) to store firmware to be 

downloaded. 

  

Figure 2-28 Select destination space 
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Step 2: Click “Tool->Multi-address download” or press the shortcut key “Ctrl + P”, so 

as to open the “Multi-address Download” interface. 

 

Figure 2-29 Open “Multi-address Download” interface 
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Step 3: Click the “Add” button so as to add firmware file and set target address. 

 

 

Step 4: Add the path of firmware 1 to the list and set the offset of starting address to 

store this firmware. 

1) First, select the first line (No.1), and click the “File” button to add target bin file 

(e.g. “Telink.bin”) to the list. The corresponding directory will be shown in the 

“File Path” column. 

 

 

Figure 2-30 Add FW 
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2) Then set the offset of starting FLASH address to store this firmware in the “Start 

Address(H)” column.  

To ensure that the destination area for firmware storage is valid, the tool will 

automatically calculate the firmware size and end address, and then show the 

calculation result in the “File Size(Bytes)” and “End Address(H)” column. 

 

 

Figure 2-31 Set offset address 

 

Step 5: Refer to step 4 to add the path of firmware 2 to the list and set the offset of 

starting address to store this firmware. 
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Step 6: Click the “Download” button to download the added firmware1 and 

firmware2 into the specific memory locations of the target board. 

 

 

 

 

Figure 2-32 Start downloading 

Step 7: After downloading all firmware into the target board, click the “Reset” button 

to make program run without the need to power cycle the target board.  
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Figure 2-33 Reset 

2.2 Flash sector erase  

    The “Flash sector erase” function is used to erase specific flash space starting 

from specific address in unit of 4kB. 

For example, to erase 64kB flash space starting from address 0x040000, user can 

follow the steps below. 

Step1: Click the “Setting” button to open the Setting dialog. Select the “FLASH” setting 

option. 

To set the starting address of flash space to be erased, e.g. 0x040000 (default 

option: 0x000000), user can either select the offset option (if available) via the drop-

down menu of “Erase Flash Addr” or directly input the offset address in the editable 

box.   
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Figure 2-34 Select starting address 
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Step2: To set the size of flash space to be erased in unit of 4kB, e.g. 64kB (default 

option: 512kB), user can either select the size option (if available) via the drop-down 

menu of “Sector Erase Size” or directly input the size in the editable box. 

 

Figure 2-35 Set erase size 
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Step3: Click the “Erase” button to start erasing the specified flash space of the target 

board.  

 

Figure 2-36 Erase 512kB flash space starting from 0x000000 
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2.3 Activate MCU 

The function of “Activate MCU when communication with target board failed” 

only applies to Swire connection between “Burning EVK” and target board in “EVK” 

mode, i.e. it does NOT support “USB” mode or USB connection between “Burning EVK” 

and target board in “EVK” mode.  

When firmware burning fails, please ensure the target board is connected with 

“Burning EVK” via Swire, and then click the “Activate” button to enable this function 

to activate the MCU. 

 

Figure 2-37 Activate MCU 
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2.4 Debug 

After MCU starts running, to access memory space (flash/core/analog/otp), user 

can open the “Memory Access” window as shown in Figure 2-38 by directly pressing 

the shortcut key combination “Ctrl + M”, or by clicking “Tool->Memory Access”.  

 

Figure 2-38 “Memory Access” interface 

 

Table 2-1 Item list of Memory Access 

ITEMS Value list Default Shortcut 

MCU Type 8366/8368/8266/8267/8269/8232/8233/8x5x 8258 Ctrl+Q 

Communication 

Mode 
EVK(Burning EVK)/USB EVK Ctrl+W 

Operation 

Destination 
FLASH/CORE1/ANALOG2/OTP CORE Ctrl+E 

Operation Size 

(Unit: Byte) 
1/2/4/8/16 1 Ctrl+R 

Address 0 0 Ctrl+A 

Data 0 0 Ctrl+D 

                                                   

1 CORE includes digital registers and SRAM. 
2 ANALOG means analog registers. 
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2.4.1 Access memory 

2.4.1.1 Read data from memory space  

To read data from specific memory space (FLASH/CORE/ANALOG/OTP), user can 

follow the steps below: 

Step1: Select MCU type (e.g. “8258”) and communication mode (e.g. “EVK”) with 

target board on the “Memory Access” window. 

*Note: If you select “USB” mode to communicate with target board, please ensure that 

the selected MCU supports USB function and its USB function is available. 

 

Figure 2-39 Select MCU type and communication mode 
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Step2: Select operation destination (e.g. “CORE”) and set operation size (e.g. “16”) on 

the “Memory Access” window. 

*Notes:  

 If you select “OTP” as operation destination, please ensure that the selected MCU 

supports “OTP” function.  

 To set operation size, user can either select the size option (if available) via the 

drop-down menu, or directly set the size in the editable box. 

 The maximum operation size is 1MB. 

 

 

Figure 2-40 Set operation destination and size 
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Step3: Move mouse cursor to the “addr” box, and then input the offset of the starting 

address to be read (e.g. “0x040000”). Keep the cursor in the “addr” box, by clicking 

the “Tab” key, user can read data from the specified memory space. 

*Notes:  

1) Every time when clicking the “Tab” key to initiate a memory reading operation, 

the value of editable box will be saved, so that you can directly select it via the 

drop-down menu next time. 

 

Figure 2-41 Set starting address and initiate reading  
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2) When reading memory space (e.g. CORE) larger than 1kB, the read data will be 

automatically saved to a file named “Read.bin” under the “user” folder.  

User can also use specific command line to change the name of file to save the 

read data. Refer to section 2.6 Command line for details.  

 

Figure 2-42 Save read data 
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2.4.1.2 Write data into memory space 

 To write data into specific memory space, user can follow the steps below: 

Step1: Select MCU type (e.g. “8258”) and communication mode (e.g. “EVK”) with 

target board on the “Memory Access” window. 

*Note: If you select “USB” mode to communicate with target board, please ensure that 

the selected MCU supports USB function and its USB function is available. 

 

Figure 2-43 Memory Access Window 
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Step2: Select operation destination (e.g. “CORE”) and set operation size (e.g. “16”) on 

the “Memory Access” window. 

*Notes:  

 If you select “OTP” as operation destination, please ensure that the selected MCU 

supports “OTP” function.  

 To set operation size, user can either select the size option (if available) via the 

drop-down menu, or directly set the size in the editable box. 

 The maximum operation size is 256 bytes. 

 

Figure 2-44 Set Operation Size 
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Step3: Move mouse cursor to the “addr” box, and then input the offset of the starting 

address to be written (e.g. “0x040000”). 

 

Figure 2-45 Offset of the Starting Address 

*Note: When operation destination is selected as “CORE”, if the address you set is less 

than the starting address of “SRAM”, the destination memory space that is actually 

accessed is digital register; if the address you set is greater than the starting address 

of “SRAM”, the destination memory space that is actually accessed is SRAM.  
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Step4: Write data to the specified address. 

Move mouse cursor to the “data” box, and then input the target data to be written. 

Keep the cursor in the “data” box, by clicking the “Enter” key, user can write the 

specified data into the specified memory space. 

*Note: When inputting the data, bytes must be separated from each other with space, 

as shown below: 

 

Figure 2-46 Set data and initiate writing 
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2.4.2 Operate Variable List 

Before viewing all global variables, please ensure that the “.lst” file and the “.bin” 

file are placed under the same directory as shown in the following two supported cases. 

Case 1: If only one pair of “.lst” file and the “.bin” file are placed under the same 

directory, this “.lst” file will be selected automatically.  

 

Case 2: if multiple“.lst” files and the “.bin” file are placed under the same directory, 

the “.lst” file with the name same as the selected “.bin” file will be selected 

automatically. 

 

For example, if you select the “Telink.bin” file, the “Telink.lst” file will be selected 

automatically. If there is no “Telink.lst” and only one “xxx.lst” file is placed under the 

directory containing the selected “Telink.bin” file, this sole “xxx.lst” file will be selected.  
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2.4.2.1 Update variable list 

To look through all global variables, user can select the “Tdebug” page, move 

mouse cursor to variable list, and then right click the mouse to choose “Refresh” or 

press the shortcut key “F3”. Each time by pressing “F3” anytime, variable list can be 

updated once. 

 

Figure 2-47 Update variable list 
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2.4.2.2 Sort variables 

As needed, user can also right click mouse, and choose the “Sort by address” to 

sort all variables by address from low to high (default), or choose the “Sort by name” 

to sort all variables by ASCII code value of variable name from A to z (compare the first 

different character). 

 

Figure 2-48 Sort variable by name 
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2.4.2.3 View variable above 4 bytes 

If a variable’s length is larger than 4 bytes, by clicking the “…” in the “Value” 

column of the “variable list”, its value will be available on the right log window.  

If a variable’s length is greater than 1024 bytes, all values of the variable will be 

saved in a file named “Read.bin”. 

 

Figure 2-49 Read variable value more than 4 bytes 
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2.4.2.4 Modify variable value 

The variable with the length no more than 4 bytes supports direct write operation, 

which means that its value can be directly modified by double clicking the 

corresponding box in the “Value” column.  

For example, to modify the value of the variable “adc_vref_cfg” in the address 

“0x41100” to “0x00000004”, user can follow the steps below:  

Step 1: Double click the box in the “Value” column corresponding to the specified 

variable (e.g. “adc_vref_cfg”), so as to make the box become editable.  

 

 

Figure 2-50 Double click specified “Value” box 

  



                  Telink Burning and Debugging Tool (BDT) User Guide 

AN-18101200-E2           55 Ver 1.1.0 

Step 2: Input new variable value (e.g. “0x00000025”) to replace the old value 

(“0x00000004”).  

 

Figure 2-51 Modify variable value 
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Step3: Press the “Enter” key to write the new value into the specified variable’s 

address.  

 
Figure 2-52 Write data to specified address 
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2.4.3 Debug MCU 

Before using the buttons including “Run”, “Pause”, “Step” and “PC” to debug MCU, 

please ensure that the selected MCU supports this function. Refer to section 4 

Function Support List for details.  

In the sub-sections below, the MCU “8258” is taken as an example to introduce 

this function. 

 

2.4.3.1 Run MCU 

After clicking the “Pause” or “Step” button, user can make MCU continue to run 

from the current position by clicking the “Run” button. Please check the status of MCU 

by clicking the “PC” button to read PC and ensure program is running again. 

 

Figure 2-53 Run MCU 

  



                  Telink Burning and Debugging Tool (BDT) User Guide 

AN-18101200-E2           58 Ver 1.1.0 

2.4.3.2 Pause MCU 

 To view the status of MCU for details, user can click the “Pause” button to stall 

MCU. Click the “Run” button, MCU will continue to run from the current position.  

 

Figure 2-54 Pause MCU 
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2.4.3.3 Step MCU 

If the communication with target board is available, user can click the “Step” 

button to view the current position of instruction step by step.  

Both “Trace MCU” and “Step MCU” support two modes, as shown below.  

1) If the “Single step” mode is selected, MCU will enter single step mode, in which 

one PC tracing will be implemented after clicking the “PC” or “Step” button.  

2) If the “continuous” mode is selected, MCU will enter continuous mode and 

implement continuous PC tracing or make MCU step continuously.   

 

To cancel “continuous” mode, user can either switch mode to “Single step” mode, 

or click the “Run”/“Pause” button.  

 

Figure 2-55 Step MCU in “Single step” mode 
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Figure 2-56 Step MCU in “continuous” mode 

If the target firmware (bin file) and “xxx.lst” file are under the same directory, user 

can view more details by selecting “View->interp .lst” and clicking the “PC” button to 

analyze the “xxx.lst” file, as shown below. Refer to section 2.4.2 Operate Variable List.  
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Figure 2-57 Select “interp .lst” 

 

 

Figure 2-58 Step MCU with “interp .lst” selected in “Single step” mode  

 

  

Figure 2-59 Step MCU with “interp .lst” selected in “continuous” mode 
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2.4.3.4 Trace PC 

If the communication with target board is available, user can click the “PC” button 

to view the current position of instruction, as shown below: 

 

Figure 2-60 Trace PC in “Single step” mode 

 
Figure 2-61 Trace PC with “interp .lst” selected in “Single step” mode 
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Figure 2-62 Switch “Single step” mode to “continuous” mode 

 

Figure 2-63 Trace PC with “interp .lst” selected in “continuous” mode 
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2.4.3.5 Stall MCU 

When there is no enough time to view the status of MCU, user can click the “stall” 

button to stall MCU and view the status of MCU or change the configuration of MCU. 

 

Figure 2-64 Stall MCU 

 

*Note: In EVK mode, only the EVK burned with the “Firmware_v3.2.bin” (or higher 

version) supports this function.  
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2.4.3.6 Start MCU 

  After stalling MCU, click the “start” button to start MCU, so that MCU will run 

from the beginning of SRAM. 

 

Figure 2-65 Start MCU 
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2.5 Single-wire synchronization 

Before setting Single wire synchronization speed, please ensure the following 

items: 

1) Power supply is normal; 

2) MCU IS NOT in “Low Power” mode; 

3) Single wire function of MCU is available; 

4) System clock is normal. 

 

When connection fails to be established between “Burning EVK” and the target 

board, user can try to set Swire (single wire) synchronization speed to improve 

communication. *Note: Swire register address may vary with different chip types. 

1) Change the speed of Master and the speed of Slave in the four editable boxes, 

as shown below. Note that Swire register address may vary with chip types. 

2) Click the “SWS” button to implement Swire synchronization. 

 

Figure 2-66 Set Swire synchronization speed 
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Before downloading firmware to target board or debugging MCU, it is suggested 

that every time on MCU power on, user should implement one Swire synchronization 

to check whether communication with target board is OK.  

 If the status of communication with target board is wrong, user can solve the 

problem according to the methods mentioned at the beginning of section 2.5. 
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2.6 Command line 

User can also use command line to access memory or download file into target 

board. In the sub-sections below, “read core” is taken as an example. 

 

2.6.1 Single command line 

Step 1: Open command line input window by selecting the “Tool->Cmdline Input” or 

pressing the shortcut key combination “Ctrl + I”.  

 

 
Figure 2-67 Open cmdline input window 
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Step 2:  Input the needed single command as follows and then press the “Enter” key. 

The file with the specified named will be available in the specified location.  

 

Figure 2-68 Enter single command line 
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2.6.2 Multi-command line 

The tool supports multi-command line operation.  

All commands need to be separated from each other by semicolon, as shown 

below. 

 

 

Figure 2-69 Enter multiple commands  
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2.7 Log windows 

This tool supports USB print function, so MCUs with USB function can use USB 

print function to output information in log windows on PC side. 

Step 1: Click the “View->usb log” to open usb log windows.  

 

 

Figure 2-70 Open usb log windows 
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Step 2: In the “usb log” mode, all output characters will be displayed in “Ascii” mode; 

 

Figure 2-71 Display output characters 

Step 3: Click the “View->usb log” again to exit the “usb log” mode. 

 

Figure 2-72 Exit usb log mode 
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2.8 Help 

By clicking the “Help->Command line”, all commands will be shown in log 

windows of the “Download” or “Tdebug” page.  

 

 

 

Figure 2-73 Show all commands 
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By clicking the “Help->User guide”, the embedded “Help” document “Telink 

Burning and Debugging Tool (BDT) User Guide” will be opened, as shown below. 

 

 

 

Figure 2-74 Open Help document 

  



                  Telink Burning and Debugging Tool (BDT) User Guide 

AN-18101200-E2           75 Ver 1.1.0 

To get more information about Telink, user can click the “Help->About Telink”. 

 

 
 

 

Figure 2-75 Get information about Telink 
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2.9 Default configuration 

Open the folder “config” in the root directory of this tool as follows. 

 

All default configurations in this tool can be changed by modifying the “config.ini” 

file. Following shows detailed explanations. 

 

 ① MCU Type:8368 

 ② The path of the firmware: \bin\dut_8368_flash_v0246.bin 

 This firmware is used to operate flash, e.g. download the specified firmware into 

flash, read/write flash, erase sectors of flash and check flash data when downloading 

firmware to flash or erase some sector of flash 

 ③ SRAM Starting Address: 0x8000, e.g.8258:0x40000; 

 ④ Single wire communication: 

1) Swire register base address of master device:0xb0 

2) Swire clock of master device:0x10 

3) Swire register base address of slave device:0xb0 

4) Swire clock of slave device:0x10 

 ⑤ The path of the firmware:  

Firmware1: \bin\dut_8368_otp_v0005.bin, which is used to operate OTP, e.g. 

download firmware to OTP, read/write OTP, check OTP data during writing data to 

OTP or downloading firmware to OTP or write data to OTP 

 Firmware2: \bin\dut_8368_otp_normal_v0002.bin,which is used to check OTP 

data during downloading firmware to OTP or write date to OTP 

 ⑥ default: 8258 

 
① Mode of Communication: USB 

 ② default: EVK(Burning EVK) 

 
① Access Objection: FLASH 

 ② default: CORE 

1 
1 

1 1 1 1 
2 3 4 5 

6 

1 
2 

1 
1 

1 
2 
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① Size of Read / Write data: 2 

 ② default: 1 

 

① Download address: 0x20000 

 ② default: 0 

 

① Erase address: 0x20000 

 ② default: 0 

 

① Page Display: 1 - Tdebug 

 ② default: 0 - Download 

 

① The Name of Button1: example1 

 ② The property of Button1: external executable application 

 ③ The Path of external executable application: E:\1_wtcdb\tcdb.exe uart -1 –u 

④ undefined Button: Button4 

 The property of Button includes three types: 

1) external_exe: external executable application 

2) internal_exe: internal executable application, which means this tool. 

3) external_file: open any external file by default 

 

① The Path of firmware: “C:\Users\Administrator\Desktop\Telink.bin” 

Download this firmware into target board to update firmware. When there’re too 

many file paths, you can directly delete these. However, the first path can’t be deleted. 
 ② default file path: “C:\Users\Administrator\Desktop\Telink.bin” 
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3 Upgrade Firmware 

User can follow the steps below to upgrade firmware of “Burning EVK”. 

Step 1: Click “Help->Upgrade” to open the dialog window “Upgrade EVK”. 

 

Figure 3-1 “Upgrade EVK” window 

Step 2: Click the button “Read FW Version” to check the current firmware version. 

 

Figure 3-2 Check current FW version 
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Step 3: Click the “Load…” button to load the new firmware. 

 

Figure 3-3 Load new FW 

Step 4: Click the “Upgrade” button to upgrade the new firmware into the “Burning 

EVK”. Note: User MUST power cycle the EVK before using it. 

  

Figure 3-4 Upgrade FW into EVK 
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4 Function Support List 

Not all MCU types support all functions of this tool. Please refer to the table below. 

Table 4-1 Function Support List 

 

 

 


